[Cuis-dev] [Integrated] Should we rename these? Re: support for variable indexable subclasses of 8/16/32/64 bits
ten at smallinteger.com
Mon May 27 11:50:46 PDT 2019
... and since both make sense, both kinds of things should be there,
rather than only e.g. 'long'.
On 5/27/19 05:56, Juan Vuletich wrote:
>> If those selectors could be named after standard types of fixed length
>> too (like 'uintptr_t'), then great because e.g. nobody says what the
>> size of a C 'long' is.
> Yes. But 'uintptr_t' access would be 32 bit in 32 bit images, and 64 bit
> in 64 bit images. 'int16', 'int32' and 'int64' would access 2, 4 and 8
> bytes at once on every platform. So they are different thing for me.
> Both make sense.
More information about the Cuis-dev