[Cuis-dev] [Integrated] Should we rename these? Re: support for variable indexable subclasses of 8/16/32/64 bits

Andres Valloud ten at smallinteger.com
Sun May 26 22:27:31 PDT 2019

Why should accessing bytes differently need copying the bytes into a 
different class?  The bytes won't change, no?

VW has a useful abstraction for this, the class UninterpretedBytes. 
While at first similar to a regular ByteArray, UninterpretedBytes 
implements things like shortAt:, doubleAt:put: and so on.  Now you need 
just one class instead of n.

If those selectors could be named after standard types of fixed length 
too (like 'uintptr_t'), then great because e.g. nobody says what the 
size of a C 'long' is.

On 5/26/19 13:49, Juan Vuletich via Cuis-dev wrote:
> Folks, these names are getting confusing. I think we'd name them better. 
> What about ByteArray, SignedByteArray, Int16Array, SignedInt16Array, 
> Int32Array, SignedInt32Array, Int64Array, SignedInt64Array, 
> Float32Array,  Double64Array, SignedPoint16Array and SignedPoint32Array?

More information about the Cuis-dev mailing list