[Cuis-dev] [Integrated] Should we rename these? Re: support for variable indexable subclasses of 8/16/32/64 bits
luchiano at gmail.com
Sun May 26 20:49:08 PDT 2019
Ken mentions byte/half/word/double/quad... this notation seems good. This
would make ByteArray/HalfWordArray/WordArray/DoubleWordArray and also
sounds consistent and I prefer HalfWord to DoubleByte.
IntXX sounds reasonable too and it's more concise. But Float32/Double64
sound redundant, I would go either with Float32Array/Float64Array if we
choose IntXX or FloatArray/DoubleFloatArray if we choose
BTW, if we rename these we should rename variable*Subclass accordingly...
and isWords, isDoubleBytes, isDoubleWords. variableInt32Subclass:? isInt32s
On Sun, May 26, 2019 at 11:07 PM ken.dickey--- via Cuis-dev <
cuis-dev at lists.cuis.st> wrote:
> On 2019-05-26 13:49, Juan Vuletich via Cuis-dev wrote:
> > Folks, these names are getting confusing. I think we'd name them
> > better. What about ByteArray, SignedByteArray, Int16Array,
> > SignedInt16Array, Int32Array, SignedInt32Array, Int64Array,
> > SignedInt64Array, Float32Array, Double64Array, SignedPoint16Array and
> > SignedPoint32Array?
> I prefer Float64Array to Double64Array (I see reference in 64-bit CPU
> architecture docs to byte/half/word/double/quad integers as well as
> Cuis-dev mailing list
> Cuis-dev at lists.cuis.st
-------------- next part --------------
An HTML attachment was scrubbed...
More information about the Cuis-dev