[Cuis-dev] Question re: recent updates (4342)

Juan Vuletich JuanVuletich at zoho.com
Mon Aug 17 19:04:22 PDT 2020

On 8/17/2020 9:18 PM, Phil B via Cuis-dev wrote:
> Juan,
> On Mon, Aug 17, 2020 at 7:06 PM Juan Vuletich <juan at jvuletich.org 
> <mailto:juan at jvuletich.org>> wrote:
>     On 8/17/2020 2:36 PM, Phil B via Cuis-dev wrote:
>>     I tried updating straight through from 4322->4351 (i.e. ignoring
>>     the message on 4342 saying I need to restart, since that would be
>>     the only way to avoid hanging after 4342)
>     No, the message says you "need to restart the image update".
>     Transcript shows: 'Please restart [Install New Updates].'
> Right, but the issue is if I save and quit, the image hangs on 
> restart.  I didn't expect it to work, but even with your revised 4342, 
> I'm still stuck trying to restart after 4342 is applied.
>>     but it still white screens for me on restart.  Does the world
>>     state fix need to be applied either right before or right after
>>     4342? (I'm OK with a manual step if fixing it in the update
>>     changesets isn't feasible, I just need to know what the fix is
>>     and when to apply it)
>     The fixes I did were to add a Delay wait in #4342, and the new
>     #4350. But there is no need to apply them by hand. Just restart
>     the update install.
>     So, don't exit the image. Just do World / Changes... / Install New
>     Updates. That should load the new updates, up to #4351. After
>     that, saving and restarting should work.
> You see the contradiction, right?  If I'm starting from 4322, and per 
> your previous statement, I *must* save and quit after 4342 so I can 
> restart.  However, at that point things hang so I can't apply anything 
> after that.  I was going straight through thinking 'this is the only 
> way I can see to accomplish what Juan's saying... despite the update 
> telling me something different'   So I've tried both restarting after 
> 4342 as well as going straight through: neither results in a working 
> image for me.

No contradiction. Just misunderstanding. I'm doing it again right now:

- Start the image you provided, (previously added a copy of an updated 
CoreUpdates/ folder).
- Open the World menu / Changes... / Install New Updates
- Enter initials: jmv. Confirm it's me. Accept the warning.
- Wait a sec until update #4342 is installed, and Transcript says 
"Please restart [Install New Updates]."
- Open the World menu / Changes... / Install New Updates
- Updates up to 4351 get installed.
- Save as New Version.
- Quit

Saved image starts without problem.

I found that if instead of Save as New Version, you just Save and Quit, 
the resulting image can't start. I just added another update to GitHub 
for that case.

Please try again now.


Juan Vuletich

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cuis.st/mailman/archives/cuis-dev/attachments/20200817/850a1cfc/attachment.htm>

More information about the Cuis-dev mailing list