[Cuis-dev] SocketStream / Sockets issue

Justin Chandler chandler.justin.s at gmail.com
Thu Jan 7 08:52:47 PST 2021

Heya, Philip!

I'm not familiar with this code you're running currently, so someone more
knowledgeable about that would have to explain why that code doesn't work,
however after doing the same netcat port listen as you have, this code
works for me in both Cuis and Pharo:


I use this code regularly to connect Pharo to the Godot game engine.
Hopefully that works for your purposes, otherwise I'm sure someone else
will be glad to help you out!

- Justin Chandler

On Thu, Jan 7, 2021 at 4:45 AM Philip Bernhart via Cuis-dev <
cuis-dev at lists.cuis.st> wrote:

> Hi,
> I'm currently a little bit confused, maybe you can help me.
> I just tried to connect to a TCP service port (using netcat),
> running locally on port 5432 and I get a primitive failed error.
> To reproduce (nc = netcat):
> $ nc -l -p 5432
> In Cuis:
>   Feature require: 'Network-Kernel'.
>   stream := SocketStream openConnectionToHost: 'localhost' port: 5432.
> When I try the same with a different programming language,
> for example ruby, then I get a connection and no error.
> Also accessing remote services there is no issue.
> When trying localhost with port 8080 there is no isuse.
> I tried to run that also in pharo and I encountered the same
> issue.
> So what's going on here?
> Thanks,
> Philip
> --
> --
> Cuis-dev mailing list
> Cuis-dev at lists.cuis.st
> https://lists.cuis.st/mailman/listinfo/cuis-dev
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.cuis.st/mailman/archives/cuis-dev/attachments/20210107/9e9100c8/attachment.htm>

More information about the Cuis-dev mailing list